Wednesday, March 30, 2011

Complex Redistribution

An interesting lab to say the least. Hard at times to wrap your mind around which way you are permitting or denying routes.



Lab objectives




Router 2(1)

interface Loopback0
 ip address 10.1.0.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.13.2 255.255.255.0
 no fair-queue
 no dce-terminal-timing-enable
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface Serial0/1
 ip address 10.1.12.2 255.255.255.0
 no fair-queue
 no dce-terminal-timing-enable
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0

Router 3(2)

router eigrp 100
 redistribute ospf 1 route-map ospf-to-eigrp
 network 10.1.23.0 0.0.0.255
 network 10.1.24.0 0.0.0.255
 distance eigrp 90 105
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map eigrp-to-ospf
 network 10.1.12.0 0.0.0.255 area 0
!
!
!
ip http server
no ip http secure-server
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
!
route-map eigrp-to-ospf deny 5
 match tag 40
!
route-map eigrp-to-ospf permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map eigrp-to-ospf permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map eigrp-to-ospf deny 30
 match ip address 3
!
route-map eigrp-to-ospf permit 40
 set metric 300
 set tag 30
!
route-map ospf-to-eigrp deny 5
 match tag 10 20 30
!
route-map ospf-to-eigrp permit 10
 set metric 400 20 255 1 1500
 set tag 40


Router 1(3)

router eigrp 100
 redistribute ospf 1 route-map ospf-to-eigrp
 network 10.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map eigrp-to-ospf
 network 10.1.13.0 0.0.0.255 area 0
!
!
!
ip http server
no ip http secure-server
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
!
route-map eigrp-to-ospf deny 5
 match tag 40
!
route-map eigrp-to-ospf permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map eigrp-to-ospf permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map eigrp-to-ospf deny 30
 match ip address 3
!
route-map eigrp-to-ospf permit 40
 set metric 300
 set tag 30
!
route-map ospf-to-eigrp deny 5
 match tag 10 20 30
!
route-map ospf-to-eigrp permit 10
 set metric 400 20 255 1 1500
 set tag 40

Router 5(4)

interface Loopback0
 ip address 10.4.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.4.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.4.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.4.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.4.4.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.0.186 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.45.1.5 255.255.255.0
 ip ospf network point-to-point
 shutdown
 no dce-terminal-timing-enable
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface Serial0/1
 ip address 10.1.24.5 255.255.255.0
 no dce-terminal-timing-enable
!
router eigrp 100
 network 10.0.0.0
 no auto-summary

Simple Redistribution EIGRP-OSPF

Redistribution Lab Set up:


interface Loopback0
 ip address 10.1.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.1.4.1 255.255.255.0
!
interface Loopback5
 ip address 10.1.5.1 255.255.255.0
!
interface Loopback6
 ip address 10.1.6.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.100.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 no fair-queue
 no dce-terminal-timing-enable
!
interface Serial0/1
 ip address 10.1.12.1 255.255.255.0
 no dce-terminal-timing-enable
!
router eigrp 100
 network 10.1.12.0 0.0.0.255
 network 10.0.0.0
 no auto-summary

Router 2

interface Serial0/0
 ip address 10.1.23.2 255.255.255.0
 no fair-queue
 no dce-terminal-timing-enable
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface Serial0/1
 ip address 10.1.12.2 255.255.255.0
 no fair-queue
 no dce-terminal-timing-enable
!
router eigrp 100
 redistribute ospf 1 metric 100 100 100 100 100 route-map filter_ospf_to_egrp
 network 10.1.12.0 0.0.0.255
 network 10.0.0.0
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 10.1.23.0 0.0.0.255 area 0
 distribute-list 1 out
!
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list shawn seq 10 permit 10.0.0.0/8 le 24
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.3.0 0.0.0.255
access-list 1 permit 10.1.5.0 0.0.0.255
!
route-map filter_ospf_to_egrp permit 10
 match ip address prefix-list shawn

Router 4


Monday, March 28, 2011

Virtual Links, Authentication over OSPF config.




The Lab:




Router 1


interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.100.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 shutdown
 no fair-queue
 no dce-terminal-timing-enable
!
interface Serial0/1
 ip address 10.12.3.1 255.255.255.0
 encapsulation frame-relay
 shutdown
 no dce-terminal-timing-enable
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute static metric 50 metric-type 1 subnets
 network 1.1.1.1 0.0.0.0 area 0
 network 10.100.1.0 0.0.0.255 area 0
 neighbor 10.12.3.2
!
ip route 172.31.0.0 255.255.255.0 Null0
ip route 172.31.1.0 255.255.255.0 Null0
ip route 172.31.2.0 255.255.255.0 Null0
ip route 172.31.3.0 255.255.255.0 Null0

Router 2


interface FastEthernet0/0
 ip address 10.100.1.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.23.1.2 255.255.255.0
 no fair-queue
 no dce-terminal-timing-enable
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface Serial0/1
 ip address 10.12.3.2 255.255.255.0
 encapsulation frame-relay
 shutdown
 no fair-queue
 no dce-terminal-timing-enable
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 10.23.1.0 0.0.0.255 area 23
 network 10.100.1.0 0.0.0.255 area 0

Router 4


interface Loopback0
 ip address 10.20.0.1 255.255.255.255
!
interface Loopback1
 ip address 10.20.1.1 255.255.255.255
!
interface Loopback2
 ip address 10.20.2.1 255.255.255.255
!
interface Loopback3
 ip address 10.20.3.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.23.1.4 255.255.255.0
 no fair-queue
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface Serial0/1
 no ip address
 shutdown
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 10.23.1.0 0.0.0.255 area 23


Router 5


interface FastEthernet0/0
 ip address 10.100.1.5 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 7 05080F1C2243
 ip ospf priority 0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.45.1.5 255.255.255.0
 ip ospf network point-to-point
 no dce-terminal-timing-enable
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface Serial0/1
 ip address 10.12.3.3 255.255.255.0
 encapsulation frame-relay
 shutdown
 no dce-terminal-timing-enable
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 area 45 virtual-link 6.6.6.6
 network 10.45.1.0 0.0.0.255 area 45
 network 10.100.1.0 0.0.0.255 area 0
 neighbor 10.12.3.1 priority 1
 neighbor 10.12.3.2 priority 1

Router 6


interface Loopback1
 ip address 10.10.0.1 255.255.255.255
!
interface Loopback2
 ip address 10.10.1.1 255.255.255.255
!
interface Loopback3
 ip address 10.10.2.1 255.255.255.255
!
interface Loopback4
 ip address 10.10.3.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.45.1.6 255.255.255.0
 no fair-queue
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.78.1.6 255.255.255.0
 clockrate 64000
!
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 area 45 virtual-link 5.5.5.5
 network 10.45.1.0 0.0.0.255 area 45
 network 10.78.1.0 0.0.0.255 area 78

Router 7


interface Serial0
 ip address 10.78.1.7 255.255.255.0
 no fair-queue
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
 network 10.78.1.0 0.0.0.255 area 78

Thursday, March 24, 2011

New Rack set-up with 1700's added

Picked up four 1700 routers with WIC-1T's in them for around $10 a pop off E-Bay. Probably worth it for the Modules alone, but I think they will function fine as Z-side routers. Not sure if they run OSPF, but I'd guess not MPLS/BGP, but I could be wrong.

First multilayer 3550 should arrive tomorrow(From Certificationkits.com) Been thinking possibly about attending Cisco Live if I can get the company to chip in something like learning credits, etc. You get a free cert test and hopefully I'll be ready for Troubleshoot by July.





Monday, March 14, 2011

New Frame Relay setup

In working the OSPF config, I decided to reset the Frame Relay config to the newer format with Connect Statements. It's nice, obviously due to not needing multiple statements, if one has no need for multipoint with subinterfaces:


interface Serial1/0
 description FR to R1 Hub
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clock rate 64000
 no dce-terminal-timing-enable
 frame-relay intf-type dce
!
interface Serial1/1
 description FR to R2
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clock rate 64000
 no dce-terminal-timing-enable
 no frame-relay inverse-arp
 frame-relay intf-type dce
!
interface Serial1/2
 description link to R5 s1
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clock rate 64000
 no dce-terminal-timing-enable
 no frame-relay inverse-arp
 frame-relay intf-type dce
!
interface Serial1/3
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clock rate 64000
 no dce-terminal-timing-enable
 no frame-relay inverse-arp
 frame-relay intf-type dce
!
interface Serial1/4
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clock rate 64000
 dce-terminal-timing-enable
 no frame-relay inverse-arp
 frame-relay intf-type dce
!
interface Serial1/5
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Serial1/6
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Serial1/7
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
!
!
ip http server
no ip http secure-server
!
connect R1-R2 Serial1/0 102 Serial1/1 201
 !
!
connect R1-R5 Serial1/0 103 Serial1/2 301
 !
!
connect R2-R5 Serial1/1 203 Serial1/2 302
 !



Saturday, March 12, 2011

Finally got the new Study Tool


Dell Precision M6300 Workstation Laptop
This is what I wanted in the first place.
4gb, 64bit Win 7, Quadro fx1600
Battery lasts forever.
off E-bay for $280.00

didn't think I'd pick one up that cheap. Right time, right place. Should be plenty of room for Putty connection manager, Nugget vids, and the cisco route book on kindle.

Have 4 1700 series routers coming, for $35.00, simply for the 4 WIC-1T's that were in them. They should work for Z-side routers to test pingability.