Saturday, November 16, 2013

Cisco's Archive command

I have mentioned this before, but actually got to setting it up on my study rack today finally.

Because I have quite a bit of equipment now, and mixed Junos and Cisco, It's helpful now to have an archive of saved configs as I study.

There are several references I used for this:

from Cisco

https://learningnetwork.cisco.com/blogs/vip-perspectives/2013/10/30/understanding-cisco-auto-archive-feature-to-backup-configuration-file

And Daniel Patrick's RouterWrangler.com Blog:

http://www.routerwrangler.com/

it's a simple config:

archive
  path tftp://192.168.1.131/$h

The $h is a variable that will save the config with a name including the current hostname:



This pic is an example of one config saved without the $h variable, and one with.

This is basic setup. There are other options that you can set for the naming, and scheduled archiving.





Monday, November 11, 2013

initial VRF configuration for the MPLS VPN training

Continuing on the MPLS studying with the addition of the VRF on the PE routers:




ip vrf MY_COMP
rd 1:100
route-target export 1:100
route-target import 1:100
!
ip vrf YOUR_COMP
rd 1:200
route-target export 1:200
route-target import 1:200
!
!
!
interface Serial0/0/0
ip vrf forwarding MY_COMP
ip address 172.16.1.1 255.255.255.252
no fair-queue
clock rate 2000000
!
interface Serial0/1/0
ip vrf forwarding YOUR_COMP
ip address 192.168.1.1 255.255.255.252
no fair-queue
clock rate 2000000
!
router ospf 10
router-id 10.10.10.101
network 10.10.10.1 0.0.0.0 area 0
network 10.10.10.101 0.0.0.0 area 0
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.10.10.202 remote-as 1
neighbor 10.10.10.202 update-source Loopback0
neighbor 10.10.10.202 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.202 activate
neighbor 10.10.10.202 send-community extended
exit-address-family
view raw VRF config hosted with ❤ by GitHub

Saturday, November 9, 2013

MPLS VPN OSPF BGP configuration practice

With my work being mostly based in MPLS, but from a mainly GUI use standpoint, I'm trying to gain a better overall understanding of MPLS configuration.

I don't have the Alcatel Gear to play with here, nor CLI config rights yet at work, so I'm working with the next best thing, practicing on what I do have, Cisco Gear.

I'm using Levent Okvur's walkthrough on YouTube:



So here is the simple MPLS setup I'm using:



Three 1841's, one as Provider Core, and two as Provider edge devices.
Four 1720's as the CE devices.

Config on one of the PE routers:

ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
mpls label protocol ldp
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.202 255.255.255.255
!
interface Loopback1
ip address 172.16.202.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.10.10.5 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface Serial0/0/0
ip address 192.168.2.1 255.255.255.252
no fair-queue
!
interface Serial0/1/0
no ip address
shutdown
!
router ospf 10
router-id 10.10.10.202
network 10.10.10.5 0.0.0.0 area 0
network 10.10.10.202 0.0.0.0 area 0
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.10.10.101 remote-as 1
neighbor 10.10.10.101 update-source Loopback0
neighbor 10.10.10.101 next-hop-self
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.101 activate
neighbor 10.10.10.101 send-community extended
exit-address-family

Saturday, November 2, 2013

Added more Racks for Sale on EBAY.

Need to generate some income to pick up another SRX and probably another EX2200.

From Cheapo 1720/2950 racks for just over $100 to a Rack mounted, 5 device setup with a Custom menu Access server for $599.00.

Check out the racks and Buy...Buy...Buy !!!

http://www.ebay.com/itm/251362609974?ssPageName=STRK:MESELX:IT&_trksid=p3984.m1555.l2649