Tuesday, January 24, 2012

Basic Junos interface configuration


Thought I'd just throw these in here. Pretty self explanatory. I show the options available for each step of the command.

You can go directly to setting the interface IP without going into edit interface level by typing the whole command.

set interfaces em0 unit 0 family inet address 0.0.0.0/24 

Obviously the ability to enter the subnet mask in CIDR is different, and pretty handy.















Friday, January 20, 2012

Junos router initial login and configuration

Ok, I've built a small mixed Cisco/Juniper Network for OSPF studying and here is some of what I've learned as I go.



To start with, after dragging your Junos device(assuming you have your QEMU junos instance, or however you are getting to Junos up in GNS3), you will open console and get this, or something similar:


Note: when getting out of Junos windows, you have to ctrl+Alt. 

It's important to note that this boot process on your machine may take quite awhile. I don't know if it is processor or ram limited, but on my fairly robust Core i5 box with 16 gb ram, it takes 5 minutes or so. Some people on the GNS3 forums were making the assumption that they weren't getting in, I think, simply because they didn't wait long enough.

Eventually you will get a login prompt.




(you won't see the password request  on first access)

At the login prompt, you will want to enter ROOT access, so amazingly, you type "ROOT" Which will get you to the root access. Then to get to CLI from there, if a password has not been set, you once again, surprisingly, type "CLI" ;-)
And then you are here...


now to enter config level, you can type configure, or Edit.




From here, for example, you can configure the host-name etc.


FYI, if you want to run show commands from configure level, like using "do" in IOS, you need to type "run"

I'll run a show interface for the ethernet 0 interface. Note: The interface is named "em0"



To save any changes in the Junos, you will have to set the Root-Authentication. This allows multiple options but for training sake, I'm using a Plain-Text-password.


Once this is set, you can use the "commit" command to save the configuration.


That's all for now. I'll add a configuring an interface post later tonight.

***edit*** 

Yeah, obviously haven't gotten to this yet. Probably tonight.









Changing gears, working towards the JNO-1 now

After a good bit of thought about it and re-review of the Juniper Cert. Track, I've decided to work towards the first level Juniper Cert, which will be a good match for my CCNA at this point, and the work we are increasingly doing at my job.

So, I'll be preparing for the JNO-101 test, to achieve the JNCIA Associate certification. The next logical step from there would the the JNCIS-SP for service providers. This I will likely shelve until finishing the CCNP.

I hope to test for the JNO-101 by the end of February.

Tuesday, January 17, 2012

OSPF LSA Packet from Wireshark

Just thought I'd post this for those that haven't had the chance to check out Wireshark and see what's actually in one of those packets passing.


Thursday, January 12, 2012

More IOS/Junos OSPF

For those wanting to begin training in Junos and have Junos on Olive here is the Juniper learning portal link to Junos as a Second Language. You'll have to register to gain access.

https://learningportal.juniper.net/juniper/user_activity_info.aspx?id=3310

Added another Junos Router and am working with Stubs and NSSA's


Tuesday, January 10, 2012

Wireshark capture

Just a pic of wireshark running and capturing em1 on the Juniper. Only problem with this is that when you start the capture you have to reload the juniper. I wasn't sure if my config would remain. It did, but it takes forever to restart.

cisco - Juniper ospf configuration

It's coming along... Slowly

One of the things I've found is that in the Graphical representation, on the Junos routers, GNS3 doesn't apparently always label the ports correctly. em0/e0 isn't always on the correct side as it is represented in Dynamips.

But we have neighborship.


















R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1         128   FULL/BDR        00:00:39    192.168.6.1     Ethernet1/0


cisco:

R2(config)#do sh run | b int
interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial0/1
 ip address 192.168.3.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 ip address 192.168.2.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.6.2 255.255.255.0
 ip flow ingress
 ip flow egress
 ip ospf network broadcast
 full-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 100
 network 192.168.1.0
 network 192.168.2.0
 auto-summary
!
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 network 192.168.6.0 0.0.0.255 area 0


Juniper config








Tuesday, January 3, 2012

Our Chosen position #2 for job growth through 2018

Gotta like where we sit...


Now that I'm restarting in OSPF, I'm going to be attempting to integrate Junos configs into my networks as I go.

Currently, I'm still working on getting the Junos config to save. So far I can't get the Junos router to go to log-in from a saved config.