Friday, August 31, 2012

Policy Based Routing with IP SLA

To start this, a reminder that when using routers as simulated hosts, make sure you are turning ip routing OFF. And set a default gateway.

The client hosts are routers here:



Router 1


ip sla monitor 1
 type echo protocol ipIcmpEcho 200.1.1.2
 timeout 1000
 frequency 3
ip sla monitor schedule 1 life forever start-time now
!
!
!
track 1 rtr 1 reachability
!
!
interface Serial0/0
 ip address 200.1.1.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 201.1.1.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.0
 ip policy route-map POLICY
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip local policy route-map ROUTER_TRAFFIC
no ip http server
!
!
!
!
ip access-list extended CLIENT1
 permit ip host 192.168.1.20 any
ip access-list extended CLIENT2
 permit tcp host 192.168.1.21 any eq telnet
 permit tcp host 192.168.1.21 any eq 443
ip access-list extended ROUTER
 permit ip any any
route-map POLICY permit 10
 match ip address CLIENT1
 set ip next-hop 201.1.1.2
!
route-map POLICY permit 20
 match ip address CLIENT2
 set ip next-hop 200.1.1.2
!
route-map POLICY permit 30
 set ip next-hop 201.1.1.2
!
route-map ROUTER_TRAFFIC permit 10
 match ip address ROUTER
 set ip next-hop verify-availability 200.1.1.2 10 track 1
 set ip next-hop 201.1.1.2

Router 2


interface Serial0/0
 ip address 200.1.1.2 255.255.255.0
 shutdown
 serial restart-delay 0


Router 3


interface Serial0/0
 ip address 201.1.1.2 255.255.255.0
 serial restart-delay 0

Router 4


no ip routing
!
!
no ip cef
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!


interface FastEthernet0/0
 ip address 192.168.1.20 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 192.168.1.1




Router 5


no ip routing
!
!
no ip cef
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!


interface FastEthernet0/0
 ip address 192.168.1.21 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 192.168.1.1

Tuesday, August 28, 2012

BGP tuning Lab 2



 Working on the Nuggets BGP Tuning vids, which you pretty much have to figure out the basic setup yourself.

I am not sure why I am not getting secondary routes on anything other than R1. I have to assume it is a setup issue with R1 as nothing on either side is getting the secondary routes, but it is.

***Worked thru this. It's a BGP concept that I had to get my head around of how BGP limits routes to only the best route is inserted in the routing table. Anyway, here are the configs.


Router 1

interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.12.2 remote-as 5500
 neighbor 10.1.13.2 remote-as 5500
 no auto-summary

Router 2


interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/1
 ip address 10.1.24.1 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/2
 ip address 10.1.23.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.12.1 remote-as 5500
 neighbor 10.1.12.1 next-hop-self
 neighbor 10.1.23.2 remote-as 5500
 neighbor 10.1.24.2 remote-as 777
 no auto-summary

Router 3


interface Serial0/0
 ip address 10.1.13.2 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/1
 ip address 10.1.36.1 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/2
 ip address 10.1.23.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.13.1 remote-as 5500
 neighbor 10.1.13.1 next-hop-self
 neighbor 10.1.23.1 remote-as 5500
 neighbor 10.1.36.2 remote-as 777
 neighbor 10.1.36.2 route-map local_pref in
 default-metric 200
 no auto-summary
!
no ip http server
!
!
!
!
ip access-list standard routes_for_r2
 permit 200.0.0.0 0.255.255.255
ip access-list standard routes_for_r3
 permit 150.1.50.0 0.0.0.255
 permit 150.2.50.0 0.0.0.255
route-map local_pref permit 10
 match ip address routes_for_r3
 set local-preference 1000
!
route-map local_pref permit 20
 match ip address routes_for_r2
 set local-preference 10

Router 4





interface Serial0/0
 ip address 10.1.24.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.45.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 777
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.24.1 remote-as 5500
 neighbor 10.1.45.2 remote-as 911
 no auto-summary

Router 5


interface Loopback0
 ip address 150.1.50.1 255.255.255.0
!
interface Loopback1
 ip address 150.2.50.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.45.2 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/1
 ip address 10.1.57.1 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 911
 no synchronization
 bgp log-neighbor-changes
 network 150.1.50.0
 network 150.1.50.0 mask 255.255.255.0
 network 150.2.50.0
 network 150.2.50.0 mask 255.255.255.0
 redistribute connected route-map filter
 neighbor 10.1.45.1 remote-as 777
 neighbor 10.1.57.2 remote-as 711
 no auto-summary
!
no ip http server
!
!
!
access-list 50 permit 150.1.50.0
access-list 50 permit 150.2.50.0
route-map filter permit 10
 match ip address 50

Router 6




interface Serial0/0
 ip address 10.1.36.2 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/1
 ip address 10.1.67.1 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 777
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.36.1 remote-as 5500
 neighbor 10.1.67.2 remote-as 711
 no auto-summary

Router 7


interface Loopback0
 ip address 200.50.2.1 255.255.255.0
!
interface Loopback1
 ip address 200.60.2.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.57.2 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/1
 ip address 10.1.67.2 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 711
 no synchronization
 bgp log-neighbor-changes
 network 200.50.2.0
 network 200.60.2.0
 neighbor 10.1.57.1 remote-as 911
 neighbor 10.1.67.1 remote-as 777
 no auto-summary




Sunday, August 26, 2012

IBGP and EBGP basic tuning 1 and 2

Router 1


interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 10.1.13.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.12.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.13.0 0.0.0.255 area 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 5500
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary

Router 2


interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.24.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.24.0 0.0.0.255 area 0

Router 3


interface Serial0/0
 ip address 10.1.13.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.34.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 10.1.13.0 0.0.0.255 area 0
 network 10.1.34.0 0.0.0.255 area 0

Router 4


interface Loopback4
 ip address 4.4.4.4 255.255.255.255
!
interface Serial0/0
 ip address 10.1.24.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.34.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 ip address 10.1.45.1 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.1.24.0 0.0.0.255 area 0
 network 10.1.34.0 0.0.0.255 area 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 5500
 neighbor 1.1.1.1 update-source Loopback4
 neighbor 1.1.1.1 next-hop-self
 neighbor 10.1.45.2 remote-as 6500
 no auto-summary

Router 5


interface Loopback10
 ip address 200.1.1.1 255.255.255.0
!
interface Loopback11
 ip address 200.1.2.1 255.255.255.0
!
interface Loopback12
 ip address 200.1.3.1 255.255.255.0
!
interface Loopback13
 ip address 200.1.4.1 255.255.255.0
!
interface Loopback14
 ip address 200.1.5.1 255.255.255.0
!
interface Loopback15
 ip address 200.1.6.1 255.255.255.0
!
interface Loopback20
 ip address 50.1.1.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.45.2 255.255.255.0
 serial restart-delay 0
 clock rate 201600
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 6500
 no synchronization
 bgp log-neighbor-changes
 network 50.1.1.0 mask 255.255.255.0
 redistribute connected route-map filter
 neighbor 10.1.45.1 remote-as 5500
 no auto-summary
!
no ip http server
!
!
!
access-list 50 permit 200.1.1.0
access-list 50 permit 200.1.3.0
access-list 50 permit 200.1.2.0
access-list 50 permit 200.1.4.0
route-map filter permit 10
 match ip address 50




Wednesday, August 22, 2012

Advanced Route Redistribution






Router 1


!
interface Loopback0
 ip address 10.1.0.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.13.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0

R2


interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.24.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 10.1.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 100
 redistribute ospf 1 route-map ospf-to-eigrp
 network 10.1.23.0 0.0.0.255
 network 10.1.24.0 0.0.0.255
 distance eigrp 90 105
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map eigrp-to-ospf
 network 10.1.0.0 0.0.0.255 area 0
 network 10.1.12.0 0.0.0.255 area 0
!
no ip http server
!
!
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
route-map eigrp-to-ospf deny 5
 match tag 40
!
route-map eigrp-to-ospf permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map eigrp-to-ospf permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map eigrp-to-ospf deny 30
 match ip address 3
!
route-map eigrp-to-ospf permit 40
 set metric 300
 set tag 30
!
route-map ospf-to-eigrp deny 5
 match tag 10 20 30
!
route-map ospf-to-eigrp permit 10
 set metric 400 20 255 1 1500
 set tag 40

Router 3


interface FastEthernet0/0
 ip address 10.1.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.13.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 100
 redistribute ospf 1 route-map ospf-to-eigrp
 network 10.1.23.0 0.0.0.255
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map eigrp-to-ospf
 network 10.1.0.0 0.0.0.255 area 0
 network 10.1.13.0 0.0.0.255 area 0
!
no ip http server
!
!
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
route-map eigrp-to-ospf deny 5
 match tag 40
!
route-map eigrp-to-ospf permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map eigrp-to-ospf permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map eigrp-to-ospf deny 30
 match ip address 3
!
route-map eigrp-to-ospf permit 40
 set metric 300
 set tag 30
!
route-map ospf-to-eigrp deny 5
 match tag 10 20 30
!
route-map ospf-to-eigrp permit 10
 set metric 400 20 255 1 1500
 set tag 40

Router 4


interface Loopback0
 ip address 10.4.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.4.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.4.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.4.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.4.4.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.24.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
!
no ip http server
!
!
!
access-list 3 permit 10.4.4.0 0.0.0.255



Saturday, August 18, 2012

Simple Redistribution

We're rolling now...

Router 1


interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.1.4.1 255.255.255.0
!
interface Loopback5
 ip address 10.1.5.1 255.255.255.0
!
interface Loopback6
 ip address 10.1.6.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 serial restart-delay 0

!
router eigrp 100
 network 10.0.0.0
 no auto-summary

Router 2


interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.23.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 100
 redistribute ospf 1 metric 100 100 100 100 100 route-map ospftoeigrp
 network 10.1.12.0 0.0.0.255
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 no auto-cost
 redistribute eigrp 100 metric 100 subnets
 network 10.1.23.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 0
 distribute-list 1 out
!
no ip http server
!
!
!
!
ip prefix-list shawn seq 5 permit 10.0.0.0/8 le 24
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.3.0 0.0.0.255
access-list 1 permit 10.1.5.0 0.0.0.255
route-map ospftoeigrp permit 10
 match ip address prefix-list shawn

Router 3


interface Loopback7
 ip address 10.1.7.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback8
 ip address 10.1.8.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback9
 ip address 10.1.9.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback10
 ip address 10.1.10.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback11
 ip address 10.1.11.1 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback12
 ip address 10.1.11.5 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback13
 ip address 10.1.11.9 255.255.255.252
 ip ospf network point-to-point
!
interface Serial0/0
 ip address 10.1.23.3 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 10.1.23.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 0



Thursday, August 16, 2012

OSPF Special Areas - auth+virtual links

Going to be another bigun'


Will add configs when I'm finished...
done...

Router 1

interface FastEthernet1/0
 ip address 10.100.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute static metric 50 metric-type 1 subnets
 network 10.100.1.0 0.0.0.255 area 0
!
no ip http server
!
ip route 173.30.0.0 255.255.255.0 Null0
ip route 173.30.1.0 255.255.255.0 Null0
ip route 173.30.2.0 255.255.255.0 Null0
ip route 173.30.3.0 255.255.255.0 Null0


Router 2

interface Loopback0
 ip address 172.31.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.31.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.31.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.31.3.1 255.255.255.0
!
interface Serial0/0
 ip address 10.23.1.1 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 10.100.1.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 23 stub no-summary
 area 23 default-cost 100 
 network 10.23.1.0 0.0.0.255 area 23
 network 10.100.1.0 0.0.0.255 area 0
 network 172.31.0.0 0.0.255.255 area 0


Router 3

interface Serial0/0
 ip address 10.23.1.2 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 stub
 area 23 default-cost 100 
 network 10.23.1.0 0.0.0.255 area 23
 network 172.31.0.0 0.0.255.255 area 23


Router 4

interface Serial0/0
 ip address 10.45.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 10.100.1.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 area 45 stub
 network 10.45.1.0 0.0.0.255 area 45
 network 10.100.1.0 0.0.0.255 area 


Router 5

interface Serial0/0
 ip address 10.45.1.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 area 45 stub
 network 10.45.1.0 0.0.0.255 area 45


Router 6

interface Serial0/0
 ip address 10.67.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet1/0
 ip address 10.100.1.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 area 67 virtual-link 7.7.7.7
 network 10.67.1.0 0.0.0.255 area 67
 network 10.100.1.0 0.0.0.255 area 0


Router 7

interface Serial0/0
 ip address 10.67.1.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.78.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
 area 67 virtual-link 6.6.6.6
 network 10.67.1.0 0.0.0.255 area 67
 network 10.78.1.0 0.0.0.255 area 78


Router 8

interface Serial0/0
 ip address 10.78.1.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 8.8.8.8
 log-adjacency-changes
 network 10.78.1.0 0.0.0.255 area 78


Saturday, August 11, 2012

OSPF over NBMA Networks

I'm not sure I have ever covered this Nugget all the way through set up.

It's a doozy... I'll add the configs when I'm done.

Old azz Core2Duo 2.4 with Win7 64 4 gb Ram is holding up pretty well with 8 routers up, all console windows open.



FRS1


frame-relay switching
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 logging event dlci-status-change
 serial restart-delay 0
 clock rate 201600
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
 frame-relay route 103 interface Serial0/2 301
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
 no ip address
 encapsulation frame-relay
 logging event dlci-status-change
 serial restart-delay 0
 clock rate 64000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103



Router 1


interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/0.1 multipoint
 ip address 10.12.3.1 255.255.255.0
 frame-relay map ip 10.12.3.2 102 broadcast
 frame-relay map ip 10.12.3.3 103 broadcast
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.12.3.0 0.0.0.255 area 0
 neighbor 10.12.3.3
 neighbor 10.12.3.2

Router 2


interface Loopback0
 ip address 2.2.2.2 255.255.255.252
!
interface Serial0/0
 ip address 10.12.3.2 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 10.12.3.1 201 broadcast
 frame-relay map ip 10.12.3.3 201 broadcast
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/1.1 point-to-point
 ip address 10.24.0.2 255.255.255.0
 frame-relay interface-dlci 204
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.12.3.0 0.0.0.255 area 0
 network 10.24.0.0 0.0.0.255 area 24

Router 3

interface Loopback0
 ip address 3.3.3.3 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0/0
 ip address 10.12.3.3 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 frame-relay map ip 10.12.3.1 301 broadcast
 frame-relay map ip 10.12.3.2 301 broadcast
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/1.1 multipoint
 ip address 10.35.6.3 255.255.255.0
 ip ospf network point-to-multipoint
 ip ospf hello-interval 10
 frame-relay map ip 10.35.6.5 305 broadcast
 frame-relay map ip 10.35.6.6 306 broadcast
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 10.12.3.0 0.0.0.255 area 0
 network 10.35.6.3 0.0.0.0 area 356

FRS2

frame-relay switching
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 serial restart-delay 0
 clock rate 201600
 frame-relay intf-type dce
 frame-relay route 204 interface Serial0/1 402
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 serial restart-delay 0
 clock rate 201600
 frame-relay intf-type dce
 frame-relay route 402 interface Serial0/0 204


Router 4

interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/0.1 point-to-point
 ip address 10.24.0.4 255.255.255.0
 frame-relay interface-dlci 402
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 24
 network 10.24.0.0 0.0.0.255 area 24

FRS3

frame-relay switching
!
!
!
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 logging event dlci-status-change
 serial restart-delay 0
 clock rate 201600
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 305 interface Serial0/1 503
 frame-relay route 306 interface Serial0/2 603
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 201600
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 503 interface Serial0/0 305
!
interface Serial0/2
 no ip address
 encapsulation frame-relay
 logging event dlci-status-change
 serial restart-delay 0
 clock rate 201600
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 603 interface Serial0/0 306

Router 5

interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/0.1 point-to-point
 ip address 10.35.6.5 255.255.255.0
 frame-relay interface-dlci 503
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 356
 network 10.35.6.0 0.0.0.255 area 356

Router 6

interface Loopback0
 ip address 6.6.6.6 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial0/0.1 point-to-point
 ip address 10.35.6.6 255.255.255.0
 frame-relay interface-dlci 603
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 356
 network 10.35.6.0 0.0.0.255 area 356

Friday, August 10, 2012

Nuggets OSPF 1

Nuggets OSPF 1 Configuration






















Router 1


interface FastEthernet0/0
 ip address 172.30.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 summary-address 172.16.0.0 255.255.252.0
 redistribute static metric 200 subnets
 network 172.30.0.1 0.0.0.0 area 0
!
no ip http server
!
ip route 172.16.0.0 255.255.255.0 Null0
ip route 172.16.1.0 255.255.255.0 Null0
ip route 172.16.2.0 255.255.255.0 Null0
ip route 172.16.3.0 255.255.255.0 Null0

Router 2


interface FastEthernet0/0
 ip address 172.30.0.2 255.255.255.0
 ip ospf priority 0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.30.10.2 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 area 10 range 10.10.0.0 255.255.252.0
 network 172.30.0.2 0.0.0.0 area 0
 network 172.30.10.2 0.0.0.0 area 10

Router 3


interface FastEthernet0/0
 ip address 172.30.0.3 255.255.255.0
 ip ospf priority 0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.30.20.3 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 area 20 range 10.20.0.0 255.255.252.0
 network 172.30.0.3 0.0.0.0 area 0
 network 172.30.20.3 0.0.0.0 area 20

Router 4


interface Loopback1
 ip address 10.20.0.1 255.255.255.0
!
interface Loopback2
 ip address 10.20.1.1 255.255.255.0
!
interface Loopback3
 ip address 10.20.2.1 255.255.255.0
!
interface Loopback4
 ip address 10.20.3.1 255.255.255.0
!
interface Serial0/0
 ip address 172.30.20.4 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 network 10.0.0.0 0.255.255.255 area 20
 network 172.30.20.4 0.0.0.0 area 20

Router 5


interface Loopback1
 ip address 10.10.0.1 255.255.255.0
!
interface Loopback2
 ip address 10.10.1.1 255.255.255.0
!
interface Loopback3
 ip address 10.10.2.1 255.255.255.0
!
interface Loopback4
 ip address 10.10.3.1 255.255.255.0
!
interface Serial0/0
 ip address 172.30.10.5 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 network 10.10.0.0 0.0.255.255 area 10
 network 172.30.10.5 0.0.0.0 area 10








Friday, August 3, 2012

Bringing up FRAME RELAY

Some of the messages you should see when bringing up your DLCI's in your frame relay switch:


FRS(config-if)#frame-relay route 102 interface Serial0/2 201
FRS(config-if)# frame-relay route 103 interface Serial0/1 301
FRS(config-if)#int s0/2
FRS(config-if)#frame-relay route 201 interface Serial0/0 102
FRS(config-if)#
Aug  3 09:41:48.087: %FR-5-DLCICHANGE: Interface Serial0/0 - DLCI 102 state changed to ACTIVE
FRS(config-if)#int
Aug  3 09:41:49.631: %FR-5-DLCICHANGE: Interface Serial0/2 - DLCI 201 state changed to ACTIVE
FRS(config-if)#int s0/1
FRS(config-if)#frame-relay route 301 interface Serial0/0 103
FRS(config-if)#
Aug  3 09:42:18.087: %FR-5-DLCICHANGE: Interface Serial0/0 - DLCI 103 state changed to ACTIVE
FRS(config-if)#
Aug  3 09:42:19.679: %FR-5-DLCICHANGE: Interface Serial0/1 - DLCI 301 state changed to ACTIVE

And Checking:

FRS#sh frame-relay route
Input Intf      Input Dlci      Output Intf     Output Dlci     Status
Serial0/0       102             Serial0/2       201             active
Serial0/0       103             Serial0/1       301             active
Serial0/1       301             Serial0/0       103             active
Serial0/2       201             Serial0/0       102             active

Thursday, August 2, 2012

Nugget's lab 1

Starting from scratch CBT Nugget lab one configs



BB Router


interface Loopback0
 ip address 172.30.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.30.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.30.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.30.3.1 255.255.255.0
!
interface Loopback4
 ip address 172.30.4.1 255.255.255.0
!
interface Loopback5
 ip address 172.30.5.1 255.255.255.0
!
interface Loopback6
 ip address 172.30.6.1 255.255.255.0
!
interface Loopback7
 ip address 172.30.7.1 255.255.255.0
!
interface Loopback8
 ip address 172.30.8.1 255.255.255.0
!
interface Serial0/0
 ip address 10.1.24.1 255.255.255.252
 ip summary-address eigrp 90 172.30.0.0 255.255.248.0 5
 serial restart-delay 0
!
interface Serial0/2
 ip address 10.1.34.1 255.255.255.252
 ip summary-address eigrp 90 172.30.0.0 255.255.248.0 5
 serial restart-delay 0

router eigrp 90
 variance 2
 passive-interface default
 no passive-interface Serial0/0
 no passive-interface Serial0/2
 network 10.1.0.0 0.0.255.255
 network 172.30.0.0
 network 192.168.1.0
 no auto-summary

Router 2 (R2)


interface Serial0/0
 ip address 10.1.24.2 255.255.255.252
 serial restart-delay 0



interface Ethernet1/0
 ip address 10.1.25.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 ip address 10.1.2.2 255.255.255.0
 half-duplex

router eigrp 90
 passive-interface Ethernet1/0
 network 10.1.2.2 0.0.0.0
 network 10.1.24.2 0.0.0.0
 network 10.1.25.2 0.0.0.0
 no auto-summary

Router 3(R3)



interface Serial0/2
 ip address 10.1.34.2 255.255.255.252
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 10.1.2.3 255.255.255.0
 half-duplex

router eigrp 90
 network 10.1.2.3 0.0.0.0
 network 10.1.34.2 0.0.0.0
 no auto-summary