Monday, April 4, 2011

BGP Lab 1 configuration



And here is the setup from the first BGP config vid from the CBT Nuggs series.

Router 1


Current configuration : 1053 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.13.0 0.0.0.255 area 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 5500
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary
!
no ip http server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Router 2


Current configuration : 763 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.24.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.24.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Router#copy run
Router#copy running-config st
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#sh run
Building configuration...

Current configuration : 763 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.24.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.24.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Router 3


Current configuration : 763 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
interface Serial0/0
 ip address 10.1.13.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.34.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 10.1.13.0 0.0.0.255 area 0
 network 10.1.34.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Router 4



Current configuration : 1055 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
interface Loopback4
 ip address 4.4.4.4 255.255.255.255
!
interface Serial0/0
 ip address 10.1.34.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 10.1.24.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 ip address 10.1.45.1 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.1.24.0 0.0.0.255 area 0
 network 10.1.34.0 0.0.0.255 area 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 5500
 neighbor 1.1.1.1 update-source Loopback4
 neighbor 10.1.45.2 remote-as 6500
 no auto-summary
!
ip http server
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

router 5


Current configuration : 757 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
interface Serial0/0
 ip address 10.1.45.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 6500
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.45.1 remote-as 5500
 no auto-summary
!
ip http server
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end




2 comments:

  1. Hey Shawn,

    So when I just started this CBT BGP lab. Going step by step of the lab after I had set up BGP on R5 & R4, BGP never came up. I then thought duhhh I haven't set up the IP addressing for the serial interfaces. After doing that I then got the '%BGP-3-NOTIFICATION: received from neighbor 10.1.45.2 2/3 (BGP identifier wrong) 4 bytes 0A012D01' error message.

    I came across online material saying that the reason for that error is because I've re-used the IP addresses as BGP identifers. So I then removed the IP addresses from the serial int' but again no joy, BGP still down. Looking at your config you've kept re-used the IP addresses as the BGP identifiers. In a nut shell I'm confused and stuck, please help me out. Thanks

    ReplyDelete
  2. Do you have loopback's configured ?

    ReplyDelete