Monday, July 1, 2013

Making your terminal server fancy, ;-)

In the interest of my learning proper blogger etiquette, instead of just posting his config here, I'll add a proper link to his blog:



but the jist of it results in a menu driven terminal server. The 2509 is now inserted(synaccess is back to just remote powerstip duties) and cabling is all perty again. Added a 2621xm for frame-relay duty, and the 1841 is my breakout router to provide remote access to the 2509. 

All done by menu now for the devices that I want to provide console access to:



Current topology, for all your Etherchannel goodness...





Da config

Password: 
Password: 
TermServ#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname TermServ
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host DSW1 2001 10.10.10.10
ip host DSW2 2002 10.10.10.10
ip host ASW1 2003 10.10.10.10
ip host ASW2 2004 10.10.10.10
ip host RTR2 2005 10.10.10.10
ip host RTR3 2006 10.10.10.10
ip domain-name xxx
!
!
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 ip address 10.0.2.2 255.255.255.0
 no ip directed-broadcast
 clockrate 64000
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip default-gateway 10.0.2.1
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.2.1
!
!
menu TS title ^C          
**********************************************************
CERT-RACKS Terminal Server
To exit from a device, use CTRL+SHIFT+6 then press x
**********************************************************
^C
menu TS prompt ^C Your selection : ^C
menu TS text 1 Connect to Rack1DSW1 - 3560
menu TS command 1 resume DSW1 /connect telnet DSW1
menu TS text 2 Connect to Rack1DSW2 - 3560
menu TS command 2 resume DSW2 /connect telnet DSW2
menu TS text 3 Connect to Rack1ASW1 - 3550
menu TS command 3 resume ASW1 /connect telnet ASW1
menu TS text 4 Connect to Rack1ASW2 - 3550
menu TS command 4 resume ASW2 /connect telnet ASW2
menu TS text 5 Connect to Rack1RTR2 - 1841
menu TS command 5 resume RTR2 /connect telnet RTR2
menu TS text 6 Connect to Rack1RTR3 - 1841
menu TS command 6 resume RTR3 /connect telnet RTR3
menu TS text s show all established sessions
menu TS command s show sessions
menu TS options s pause
menu TS text c<no> clear the session by number ie: c5
menu TS text e menu-exit
menu TS command e menu-exit
menu TS text q Quit terminal server session
menu TS command q exit
menu TS command c1 c1
menu TS command c2 c2
menu TS command c3 c3
menu TS command c4 c4
menu TS command c5 c5
menu TS command c6 c6
menu TS clear-screen
menu TS line-mode
alias exec c1 clear line 1
alias exec c2 clear line 2
alias exec c3 clear line 3
alias exec c4 clear line 4
alias exec c5 clear line 5
alias exec c6 clear line 6
!
line con 0
 logging synchronous
 transport input none
line 1 8
 session-timeout 35791 
 no exec
 exec-timeout 35791 0
 absolute-timeout 10000
 no history
 transport input telnet
 autohangup
 stopbits 1
line aux 0
line vty 0 4
 exec-timeout 300 0
 password cisco
 login
 autocommand menu TS

1 comment:

  1. This is by far one of the best access server configs I have seen. Thanks for sharing!

    ReplyDelete